Degraded performance on Devolutions Forum

Incident Report for Devolutions Online Services

Resolved

This incident has been resolved.
Posted Jun 19, 2025 - 14:45 EDT

Monitoring

We have re-enabled post creation for existing users. As a temporary measure, post creation is still disabled for newly created users.
Posted Jun 19, 2025 - 12:02 EDT

Update

We are currently experiencing an elevated volume of spam messages on our forum. As a temporary measure, we have disabled the creation of new posts while we investigate and address the issue.
Posted Jun 19, 2025 - 10:35 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 19, 2025 - 10:21 EDT

Investigating

We are currently investigating this issue.
Posted Jun 19, 2025 - 07:15 EDT
This incident affected: Forum.