Devolutions Jet unavailability
Incident Report for Devolutions Online Services
Resolved
This incident has been resolved.
Posted May 11, 2020 - 14:04 EDT
Monitoring
The service is stable again. We are monitoring the status closely.
Posted May 11, 2020 - 11:27 EDT
Update
The service is currently running with limited capacity. Our team are still working to restore the full service.
Posted May 11, 2020 - 11:21 EDT
Identified
An unexpected condition happened during a new release of Devolution Jet causing the current unavailability of the service. Our teams are working to restore the service as soon as possible.
Posted May 11, 2020 - 10:56 EDT
This incident affected: Devolutions Jet.