Email delivery incident

Incident Report for Devolutions Online Services

Resolved

This incident has been resolved.
Posted Jun 27, 2022 - 16:58 EDT

Update

We are performing a rollback of our infrastructure. Still monitoring the situation.
Posted Jun 27, 2022 - 16:42 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 27, 2022 - 16:14 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 27, 2022 - 16:14 EDT

Investigating

We are currently investigating this issue.
Posted Jun 27, 2022 - 15:40 EDT
This incident affected: Notifications.