Connectivity issues with Devolutions Hub

Incident Report for Devolutions Online Services

Resolved

This incident has been resolved.
Posted Mar 03, 2025 - 15:16 EST

Monitoring

Our provider has implemented a fix, and we are seeing a significant reduction in timeouts across our servers. We continue to monitor the situation closely to ensure full stability. Further updates will be provided as necessary.
Posted Mar 03, 2025 - 14:08 EST

Identified

An issue with our provider has been identified, causing intermittent connectivity problems for some users. We will continue to monitor the situation and post updates as they become available.
Posted Mar 03, 2025 - 13:44 EST

Update

We are continuing to investigate this issue.
Posted Mar 03, 2025 - 12:59 EST

Update

We are continuing to investigate this issue.
Posted Mar 03, 2025 - 12:50 EST

Investigating

Intermittent timeouts are affecting service.
Posted Mar 03, 2025 - 12:25 EST
This incident affected: Hub Business (Hub France, Hub US, Hub Canada, Hub Australia).