Password Hub intermittent issues in US region
Incident Report for Devolutions Online Services
Resolved
We can now consider this issue resolved. No more errors were reported since the fix rolled out by our cloud provider. We would like to thank you for your patience.
Posted Jun 04, 2020 - 13:42 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 04, 2020 - 11:54 EDT
Update
Our cloud service provider is currently rolling out a fix. The error rate is almost null for Password Hub service since 9:30 EST. We will continue to monitor the situation closely. Thanks for your patience.
Posted Jun 04, 2020 - 11:54 EDT
Identified
We believe the issue is related to a broader issue with our cloud service provider. The Password Hub service is still working most of the time, but you might experience some intermittent failures. If you do, please refresh the page or retry the action you just attempted. We are closely monitoring the situation and we will keep you updated as soon as we have more information. We apologize for the inconvenience.
Posted Jun 04, 2020 - 10:02 EDT
Investigating
We are currently investigating this issue.
Posted Jun 04, 2020 - 08:15 EDT
This incident affected: Devolutions Hub Business (Devolutions Hub Australia).