Cloudflare has implemented a fix and all services are now available. We are actively monitoring to ensure everything remains stable.
Posted Nov 18, 2025 - 09:49 EST
Update
We are implementing a mitigation and services are beginning to come back online. We will continue to monitor the situation and provide updates.
Posted Nov 18, 2025 - 09:30 EST
Update
We are continuing to work on a fix for this issue.
Posted Nov 18, 2025 - 08:59 EST
Update
We are continuing to work on a fix for this issue.
Posted Nov 18, 2025 - 07:47 EST
Identified
Cloudflare is experiencing a global network incident (started 11:48 UTC, Nov 18) that may cause intermittent 500 errors when accessing our services. Our team is actively monitoring the situation and Cloudflare's resolution progress. Track updates: https://www.cloudflarestatus.com/ We apologize for any disruption and will update you as soon as the issue is resolved. Thank you for your patience.
Posted Nov 18, 2025 - 07:47 EST
This incident affected: Authentication, Hub Personal, Portal, Blog, Corporate websites, Forum, Help, Notifications, Service Desk, Licenses, Store and Hub Business (Hub France, Hub US, Hub Canada, Hub Australia).