Elevated error rates with Entra ID authentication on Devolutions Cloud

Incident Report for Devolutions Online Services

Resolved

The incident has been resolved. If you are using the encryption service, you may need to restart it if you still encounter errors.
Posted Jul 14, 2026 - 11:06 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 14, 2026 - 09:16 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 14, 2026 - 05:21 EDT

Investigating

We are currently investigating this issue.
Posted Jul 14, 2026 - 03:55 EDT
This incident affected: Devolutions Cloud (formerly known as Hub Business) (France, US, Cloud (formerly known as Hub Personal), Canada, Australia).