Hub: France region is down
Incident Report for Devolutions Online Services
Resolved
This incident has been resolved.
Posted Mar 12, 2020 - 18:16 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 12, 2020 - 16:49 EDT
Investigating
We are currently investigating this issue.
Posted Mar 12, 2020 - 16:42 EDT
This incident affected: Devolutions Hub Business (Devolutions Hub Australia).