Generalized outage caused by Azure outage
Incident Report for Devolutions Online Services
Resolved
This incident has been resolved.
Posted Apr 01, 2021 - 18:47 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 01, 2021 - 18:44 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 01, 2021 - 18:04 EDT
Investigating
We are currently investigating this issue.
Posted Apr 01, 2021 - 17:43 EDT
This incident affected: Devolutions Account, Customer Portal, Blog, Corporate websites, CRM, Devolutions Jet, Forum, Help, Password Hub, Email Delivery, RDM Online Services, Wayk Bastion, and Service Desk.